Portal Slowness
Incident Report for Stackify
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 17, 2018 - 14:50 CDT
Identified
User may be experiencing slowness accessing the Retrace portal at this time. Engineering is working to resolve the issue.
Posted 3 months ago. Aug 17, 2018 - 14:03 CDT
This incident affected: Management Portal.