APM Data ingestion performance degregation
Incident Report for Stackify
Postmortem

At roughly 8:43am (CDT) we started some extremely high latency saving data to Azure storage. Latency jumped +6 seconds for saving data. This caused some extreme slowness with receiving and ingesting some APM data. As a precaution, we did a rolling restart of our affected servers. Around 9:12am the issue had resolved itself. Azure storage latency is back to normal.

Posted Mar 29, 2020 - 09:23 CDT

Resolved
Performance is back to normal
Posted Mar 29, 2020 - 09:19 CDT
Identified
We are currently observing some slowness with Azure storage. This is causing issues with receiving and ingesting some APM data.
Posted Mar 29, 2020 - 09:13 CDT
This incident affected: APM+.